[Synthetics] Protech - FEIDNN - my.financialexecutives.org

Incident Report for Protech Associates

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 09:28 EDT

Identified

https://my.financialexecutives.org/
Upon checking, the site is taking an unusually long time to load. The page does not fully load, and no specific error message is being displayed.
Posted Jul 06, 2026 - 07:58 EDT

Investigating

We have received an alert for "[Synthetics] Protech - FEIDNN - my.financialexecutives.org"
Our team is actively investigating the issue and working on the alert. We'll provide further updates shortly

Event URL :
https://protech.datadoghq.com/monitors/270349107
Posted Jul 06, 2026 - 07:57 EDT
This incident affected: Azure Tenant.